Hi, I tried to install Hialgo Switch 2.0; but whether I do it from Hialgo's official site, or another site, when I run the installer, a window that say, "you may not have the necessary permissions" keeps popping up. I tried to run as Administrator, and instead it open a strange window saying, "name file not found, please make sure it is correct". I really don't know what to do, I tried installing switch 1.0 but games crash too frequently with it...
I would use Switch mainly with Warframe.
I could not add the Image of the window, tell me if you need it to better understand the problem.
Hm-m, I just tried to download installation file - it comes down OK:


You can check whether you are getting file of the same size.

Most likely, right after you download it, your antivirus deletes or moves it, because it detects some injection abilities of this app. Try posing your antivirus before downloading, make sure that after downloading the file does not disappear etc.

If nothing helps, post some screenshots and any additional info you can think about.