vazzalucifer
I created this topic to post a list of games that actually worked using the current version (SWITCH v0.8.). Since I have a reasonable library on Steam (more than 500 games) i can test some games and then post the results here.


Work (v0.8)
- Alice Madness Returns
- Alpha Protocol
- Batman Arkham City
- Borderlands 2
- Castlevania: Lords of Shadow - Mirror of Fate HD
- Cognition: An Erica Reed Thriller
- Dead Island
- Deus Ex Human Revolution
- Dragon Age Origins
- Dungeons Siege III
- Gothic 3
- Hard Reset
- Mafia II
- Overlord
- Resident Evil Revelations HD
- Saints Row 2
- Silent Hill Homecoming
- Spec Ops: The Line
- Team Fortress 2
- The Darkness II
- The Incredible Adventures of Van Helsing
- The Elder Scroll's V: Skyrim ( HiAlgo Boost works better )
- The Last Remnant
- The Witcher 2: Assassins of Kings - Enhaced Edition
- Torchlight II
- Tropico 4
- Warlock: Master of the Arcane


Glitched (v0.8)
-
Assassin's Creed: white screen, which is strange since last version worked well
- Castlevania Lords of Shadow:SWITCH did activate but no fps boost noticed.
- Dark: Everytime you turn SWITCH v0.8 to 50% NPCs and some objects disappear.
- Dark Souls: No text and the screen keeps "flickering".
- Star Wars: The Force Unleashed 2: No image when injector is active.
- Tomb Raider: When you turn 50% the screen gets black and you can't see a thing.
- Trine: When you activate SWITCH the game turn post processing off, no fps boost noticed.



Doesn't Work (for now at least)
- Aritana and the Harpy's Feather
- Blood of the Werewolf
- Kingdoms of Amalur
- Path to Exile
- The Walking Dead Season 2
- The Wolf Among Us
Quote
Seya16
Can you try on Kingdom of amalur (if you have the of course) because it doesn't work with anymore(at least for me)
Quote
vazzalucifer
Kingdoms of Amalur is on the "Doesn't Work" list. I can hear the "beep" but the message to "activate/don't activate" the injector doesn't show up. [frown]
Quote
GreenDevil
Could you try Alien vs. Predator if you have it?
Quote
QuiteReluctant
@vazzalucifer

> I have a reasonable library on Steam (more than 500 games)

Ha-ha-ha! You mean, reasonable is a new synonym for huge? 


> Works for The Elder Scroll's V: Skyrim ( HiAlgo Boost works better )

Yes, of course! HiAlgo Boost is better by definition. But we are planning to gain experience with SWITCH and then make BOOST universal too.


Your section Glitched (v0.8) is the most useful: it provides the details. Could you provide some details for Doesn't Work (for now at least) as well? For example, your "I can hear the "beep" but the message to "activate/don't activate" the injector doesn't show up" is very useful!

Specific questions:

1. When you observe no fps boost, do you see lowered resolution at 50% setting? If not, do you try Right Alt + Space?
2. The Wolf Among Us - it does not work for you but works for me. How can we figure out why?

   -- Do you have 64-bit machine? Mine is 32-bit.
   -- How it did not work for you? Did not get injected? Did it create a folder like 

     ...\Documents\My Games\HiAlgo\SWITCH_v0.8\H[wink]Steam)steamapps)common)The Wolf Among Us)TheWolfAmongUs  ?

   If yes, what are the log files there?


Thanks for your help! [thumb]
Quote
vazzalucifer
GreenDevil I don't have this game, but i'll see if some friend have, then download with family sharing.

Well I'm glad to Help QuiteReluctant, I'll try to put more infromation on the "Glitched" and "Doesn't Work" lists.

When I say no fps boost meas that the injector says 50%, however I don't notice any difference, its the same as 100%

The injector did create a folder, but i cannot even hear the "beep" sound. I have a 64 bits system, maybe that's the reason.
The game runs fine however, since it's not very demanding, I was just trying every game I have installed to say the truth [smile]
Quote
QuiteReluctant
Quote:
When I say no fps boost means that the injector says 50%, however I don't notice any difference, its the same as 100%

Yes, this is correct. But the most likely reason for this is that by default SWITCH is trying to keep HUD sharp, but in some games it "thinks" that everything is HUD. You can change the default, either in settings for this specific game, or directly in game. If this works, I'd characterize such game as "blurred HUD" rather than "no FPS boost". (Or maybe your characterization is more correct? Or maybe we should come up with better names... Hm...)

About 64 bits:  we do not support 64-bit games, as of yet. But the game usually has two versions, and it should be possible, with some minor tricks, to cause it to run 32-version on 64-bit machine.

Quote:
The injector did create a folder

If there are log files in this folder, could you please post them somehow?
Quote
vazzalucifer
QuiteReluctant wrote:

Yes, this is correct. But the most likely reason for this is that by default SWITCH is trying to keep HUD sharp, but in some games it "thinks" that everything is HUD.


Well, I left FULL_RES_HUD = false as default, tried pressing SPACE+Alt, tried changing it but no luck. However some people says that the game works, so problably something on my system.

Quote:
About 64 bits:  we do not support 64-bit games, as of yet. But the game usually has two versions, and it should be possible, with some minor tricks, to cause it to run 32-version on 64-bit machine.


Yeah, I already noticed most games run on 32 bits, even if my system is actually 64.
I'm downloading The Darkness II right now, I'll post the results later.
Quote
QuiteReluctant
Again, thanks for your help.

Just in case:
1. You are using SPACE + Right Alt, right?
2. You set FULL_RES_HUD = false in correct settings.ini file, right?
Quote
Seya16
vazzalucifer wrote:
Kingdoms of Amalur is on the "Doesn't Work" list. I can hear the "beep" but the message to "activate/don't activate" the injector doesn't show up. [frown]

Ok thanks [smile]
Quote
vazzalucifer
QuiteReluctant wrote:
Again, thanks for your help.

Just in case:
1. You are using SPACE + Right Alt, right?
2. You set FULL_RES_HUD = false in correct settings.ini file, right?


Yup, SPACE+Alt works for Borderlands 2 and Resident Evil Revelations HD. But it didn't for other games :/
Oh, tested The Darkness II, it works.
Quote
Seya16
Don't work with Star wars the force unleashed 2. The game won't show itself while switch is activate
Quote
vazzalucifer
Ok, I'll add to the list

Edit: The Incredible Adventures of Van Helsing (works)
Quote
HiAlgoBoost
@vazzalucifer: "The Wolf Among Us" - works on my machine (win7,64bit). Lets debug... Try running Switch in administrator mode. Check the log file for error messages...
Quote
vazzalucifer
I don't have TWAU installed right now since i finished the game 100%. I'll try with The Walking Dead Season 2 which use the same engine.

Good news guys, I tried v0.8 on Dragon Age Origins, and it works now.
Also tried Saints Row 2, works too.
Quote