ShiveringBullet
I currently have Skyrim version 1.1.21.0 and I'm trying to find which download should I get.
I get really confused. Can someone help me?
Quote
QuiteReluctant
Oh boy! I recall, 1.1.21.0 was the very first version we started to work with. The latest HiAlgoBoost, 2.4x will definitely not work with it. You have to go back quite a while, maybe to before version 2.

But keep in mind, we do not support these older versions, we just can't. So, you are on your own. 

Good luck! (Or better upgrade).
Quote
ShiveringBullet
Alright thanks.
I haven't updated the game in a while, And I'm going to update it to the latest one. Thanks again for the info. [smile]

*EDIT*
I just updated it.
And got it to work. This mod is amazing.
Thank you guys for helping. :]
Quote