HiAlgo Forums
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
Jawstin

Junior Member
Registered:
Posts: 3
Reply with quote  #1 

Hi there, I'm using HialgoBoost since 5 months and I'm totally satisfied ! [comp]

But I would like to know if it is possible to use a different d3d9.dll (just the d3d9.ll, it is not a mod !)
from this guy : http://www.curse.com/mods/skyrim/skyrim-better-performance

I tried to just replace the d3d9.dll, but as I expected the new d3d9.dll was operational but HiAlgo was not working.

I also tried to rename the new d3d9.dll to d2d9_nolag.dll and enabled the proxy in the HiAlgoBoost.ini, but when I started the game it was like nothing changed just HiAlgo working...

I could really use some help, with this d3d9.dll I get +10fps but without HiAlgo FPS drops when i'm turning or moving the mouse really fast !

Thanks for help ! [rolleyes]

QuiteReluctant

Moderator
Registered:
Posts: 927
Reply with quote  #2 
just the d3d9.ll, it is not a mod !

Ha, experts disagree on this. Some wise guys call everything a mod. [smile]

as I expected the new d3d9.dll was operational but HiAlgo was not working

Right, this is how it should happen.

I also tried to rename the new d3d9.dll to d2d9_nolag.dll and enabled the proxy in the HiAlgoBoost.ini,

Well, this should  work. Skyrim Better Performance has even posted copy of HiAlgo instructions on their site, about how to hook two DLLs together. And by your description, you did exactly that. So, the catch is probably in some typo, or you switched parameters between two lines in HiAlgoBoost.ini or something similar.

Please check your d3d9.log file in My Documents\My Games\HiAlgo\ folder. It should contain lines like this

Loaded C:\Windows\system32\d3d9.dll!

but if you hooked up d3d9_nolag.dll correctly, it should also have someting like

Loaded C:\Program Files\Steam\SteamApps\common\skyrim\d3d9_nolag.dll!
Jawstin

Junior Member
Registered:
Posts: 3
Reply with quote  #3 

> Ok, good to know ! (I just meant it was just a different d3d9.dll file not linked to any big mod like enb...)

> Uhm okay... that's really strange this is my HiAlgoBoost.ini (By the way my new d3d9.dll is d3d9_other.dll not d2d9_nolag.dll, it was just an error when i typed...)

EnableProxy_d3d9     = true
ProxyLibrary_d3d9    = d3d9_other.dll

And then I have this in my d3d9.log (from the last time I launched the game)

Loaded C:\Windows\system32\d3d9.dll!

Looks like d3d9_other.dll is not loaded, however, my Skyrim launcher detect the new d3d9 (I know that because usually the video card detect low and now it detect medium)

QuiteReluctant

Moderator
Registered:
Posts: 927
Reply with quote  #4 
Still, I believe there is some simple error. Maybe you renamed HiAlgo's d3d9.dll, by mistake?
Try this:
(1) Uninstall HiAlgoBoost (using HiAlgoBoost_Uninstall.bat)
(2) Install HiAlgoBoost 
(3) Rename your d3d9.dll from www.curse.com elsewhere (into, say, d3d9_curse.dll, and then copy it in into Skyrim folder.
(4) Edit HiAlgoBoost.ini to 

EnableProxy_d3d9     = true
ProxyLibrary_d3d9    = d3d9_curse.dll

Good luck! [wave]
Jawstin

Junior Member
Registered:
Posts: 3
Reply with quote  #5 

Ok, I will try this tomorrow, just came back from Thailand, I'm exhausted, I keep you updated !

EDIT : YEAAAAAAAAAH It worked !

Loaded d3d9_curse.dll!

Thanks ! [thumb]

Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.