HiAlgo Forums
Sign up Calendar Latest Topics
 
 
 


Reply
  Author   Comment  
demondos

Junior Member
Registered:
Posts: 8
Reply with quote  #1 
http://prntscr.com/l8h8oo


"FAIL TO CREATE " FOLDER FOR CURRENT USER" error.png 

demondos

Junior Member
Registered:
Posts: 8
Reply with quote  #2 
This happens after I lunch any game when HiAlgoBoost is open. Help pls.

I deleted the HiAlgo folder that was in My Documents> My Games > Hialgo

and now I get this andhialgo.png the same error as before (see picture above).

demondos

Junior Member
Registered:
Posts: 8
Reply with quote  #3 
I uninstalled the program and reinstalled it again. I'm back to the first issue FAIL TO CREATE " FOLDER FOR CURRENT USER
QuiteReluctant

Moderator
Registered:
Posts: 894
Reply with quote  #4 
HiAlgo is trying to create a sub-folder HiAlgo in My Documents\Games

First, make sure that the folder My Documents\Games itself is there. If you see My Documents, but not Games, create Games by yourself, under My Documents.

If Games is there, check permissions for this folder. Maybe they are too restrictive. Hm, actually they should not be restrictive for the user who is currently logged on into the computer.
demondos

Junior Member
Registered:
Posts: 8
Reply with quote  #5 
I have done what you said to do. I made a "Games" folder in my documents but it still messing up. I do see a HiAlgo folder under C:\Users\Owner\Documents\My Games, I unchecked the read-only option in the properties. I still have the same issue. 

QuiteReluctant

Moderator
Registered:
Posts: 894
Reply with quote  #6 
I do see a HiAlgo folder under C:\Users\Owner\Documents\My Games

This looks correct. Hm... Do you have administrative rights on this computer? I mean, does user "Owner" has administrative rights? (Most likely it does).

Are you starting HiAlgoBoost as an Administrator? You should. This may be important.

Try to create a folder under My Games manually. Then open Notepad, type any text and save the file into this folder. (Most likely, this will work too).

============================
The original message "Failed to create '' folder..." means that HiAlgo was trying to create folder with empty name. Do you have a game installed into a folder with non-English characters? This should not matter, but just in case...

Is your harddrive almost full by any chance?

===========================
There is a chance that while you are doing various tests, you will stumble upon the thing that causes this trouble. Good luck.
demondos

Junior Member
Registered:
Posts: 8
Reply with quote  #7 
I did as you said but did not work. I do have administrative rights.
QuiteReluctant

Moderator
Registered:
Posts: 894
Reply with quote  #8 
Can you show the content of your C:\Users\Owner\Documents\My Games\HiAlgo folder? You can take a screenshot, for example.

I assume you played other games with HiAlgo, right? If not, try one, to see whether HiAlgo will work there.
demondos

Junior Member
Registered:
Posts: 8
Reply with quote  #9 
hialgo.png 
QuiteReluctant

Moderator
Registered:
Posts: 894
Reply with quote  #10 
So, there is nothing inside BOOST_v5.0 folder? Each game you are playing with HiAlgo will create a separate folder under BOOST_v5.0. Can you play any game with HiAlgoBoost? 
demondos

Junior Member
Registered:
Posts: 8
Reply with quote  #11 
hial.png These are the two folders inside BOOST_v5.0, inside them, there are a d3d9 and hookdll .log files and a settings .ini file. I can't play at all. I have tried many different games because I get the same error "FAIL TO CREATE " FOLDER FOR CURRENT USER".
QuiteReluctant

Moderator
Registered:
Posts: 894
Reply with quote  #12 
OK, so you played, or at least tried to play two games with HiAlgo, and HiAlgo created these subfolders. One game is from Razer ad another - Skillbrains. I cannot see the names of the games, because the Name column is too narrow.

You ran these two games a couple of weeks ago, on October 21. Do you remember playing these games?

As I asked you before, "Are you starting HiAlgoBoost as an Administrator?". This is different from having administrative rights. You have to right-click on the link or EXE file and select "Run as administrator".
demondos

Junior Member
Registered:
Posts: 8
Reply with quote  #13 
hia.png 


Those are not games at all, they are just programs. one of them is razer game booster and the other is light shot (so I can take screenshots). I always run Hialgo exe as an administrator.

QuiteReluctant

Moderator
Registered:
Posts: 894
Reply with quote  #14 
OK, so sometimes HiAlgo gets injected into applications that are not games, but use graphic card. These folders show that in two cases HiAlgo was able to create them.

Hm, let me ask around -- this is an interesting case.

Later note:

I just asked around. Here is a hypothesis: these two programs, RazerCortex and Lightshot (or one of them) are also getting injected into games. At least the booster should. It is possible, that there is some conflict, when HiAlgo is injected into the booster and into the game, and the booster is also injected into same game.

First step: stop all these suspects, make sure they are not running in the background. Use Task Manager for this. Then run a game without them, but with HiAlgo.

If this helps, there will be a second step, to allow these "suspects" to run again.
Previous Topic | Next Topic
Print
Reply

Quick Navigation:

Easily create a Forum Website with Website Toolbox.